using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bWORD\s*((?:(?!WORD)(?:.|\n))*?)\s*BORDERWORD\b";
string input = @"randomtext WORD rand
omtext WORD needed
text BORDERWORD random
text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}