re = /\/path-one\/[0-9]+\/status/m
str = '/path-one/12/status
/path-one/18/status
/path-one/103/status
/path-one/9821/status'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end