using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{0,1000}DELETE ME[^\r\n]*\R";
string input = @"unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}