const regex = /C([A-Z].+)T/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('C([A-Z].+)T', '')
const str = ` ABCDEFGHIJKLMNOPQRSTUVWXYZ CERTIFICATION
0123456789
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);