Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(201[0-9]-[0-9][0-9]-[0-9][0-9])(?=.*?((?i)-Test-))
/
gm
Input 1
1
New
2015-12-29-Test-Rechnungskopie.pdf 2016-12-29-Test-Prämienrechung 2015-01-20-Test-Leistungsabrechnung.pdf