#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\-?\d{1,3}(?:(?:\,\d{3})|\d)*(?:\.\d+)?(?:[Ee\^]\d+)?\ *)+$"
Local $sString = "100" & @CRLF & _
"2000" & @CRLF & _
"45,305,201,45,2506" & @CRLF & _
"-10,000,000.424" & @CRLF & _
"2015 4 4" & @CRLF & _
"592 -59285 6e4" & @CRLF & _
"204E34" & @CRLF & _
"40245.243e" & @CRLF & _
"234ggff" & @CRLF & _
"Hello, World! 4" & @CRLF & _
"261" & @CRLF & _
"1293712938712938172938172391287319237192837329" & @CRLF & _
"3.23e4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")