using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\-?\d{1,3}(?:(?:\,\d{3})|\d)*(?:\.\d+)?(?:[Ee\^]\d+)?\ *)+$";
string input = @"100
2000
45,305,201,45,2506
-10,000,000.424
2015 4 4
592 -59285 6e4
204E34
40245.243e
234ggff
Hello, World! 4
261
1293712938712938172938172391287319237192837329
3.23e4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}