// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\-?\d{1,3}(?:(?:\,\d{3})|\d)*(?:\.\d+)?(?:[Ee\^]\d+)?\ *)+$").unwrap();
let string = "100
2000
45,305,201,45,2506
-10,000,000.424
2015 4 4
592 -59285 6e4
204E34
40245.243e
234ggff
Hello, World! 4
261
1293712938712938172938172391287319237192837329
3.23e4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}