import re
regex = re.compile(r"<table[^>]*id=\"table_id2\">((?:\s*<tr[^>]*><td>[^>]*<\/td><\/tr>\s*)+)")
test_str = ("<table class=\"my_table\" id=\"table_id1\">\n"
" <tr class=\"odd\"><td>Line 1</td></tr>\n"
" <tr class=\"even\"><td>Line 2</td></tr>\n"
" <tr class=\"odd\"><td>Line 3</td></tr>\n"
" <tr class=\"even\"><td>Line 4</td></tr>\n"
"</table>\n"
"<table class=\"my_table\" id=\"table_id2\">\n"
" <tr class=\"odd\"><td>Line 1</td></tr>\n"
" <tr class=\"even\"><td>Line 2</td></tr>\n"
" <tr class=\"odd\"><td>Line 3</td></tr>\n"
"</table>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")