re = /video(([0-9]){9}?)\_(([0-9]){9}?)/
str = 'https://vk.com/video?z=video217077602_456239042%2Fpl_cat_updates'
# Print the match result
str.match(re) do |match|
puts match.to_s
end