# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Command\s+(\w+)\s+returned:\s+(.*)"
test_str = ("Command google returned: [\n"
" {\n"
" \"title\": \"Cloning a repository - GitHub Docs\",\n"
" \"href\": \"https://docs.github.com/en/repositories/creating-and-managing-repositories/cloning-a-repository\",\n"
" \"body\": \"Cloning a repository. On GitHub.com, navigate to the main page of the repository. Above the list of files, click Code . Copy the URL for the repository. To clone the repository using HTTPS, under \\\"HTTPS\\\", click . To clone the repository using an SSH key, including a certificate issued by your organization's SSH certificate authority, click SSH ...\"\n"
" },\n"
" {\n"
" \"title\": \"How to Clone a GitHub Repository - How-To Geek\",\n"
" \"href\": \"https://www.howtogeek.com/451360/how-to-clone-a-github-repository/\",\n"
" \"body\": \"Here's how to clone a GitHub repository. The first thing you'll need to do is download and install Git on your computer. The installation process is straightforward and brings you through a lot of boilerplate information. The one thing you want to be careful with is that you allow Git to be used from the command line.\"\n"
" },\n"
" {\n"
" \"title\": \"Git - git-clone Documentation\",\n"
" \"href\": \"https://www.git-scm.com/docs/git-clone\",\n"
" \"body\": \"Reject to clone a repository if it is a shallow one, can be overridden by passing option --reject-shallow in command line. See git-clone[1] clone.filterSubmodules . If a partial clone filter is provided (see --filter in git-rev-list[1]) and --recurse-submodules is used, also apply the filter to submodules.\"\n"
" },\n"
" {\n"
" \"title\": \"git clone | Atlassian Git Tutorial\",\n"
" \"href\": \"https://www.atlassian.com/git/tutorials/setting-up-a-repository/git-clone\",\n"
" \"body\": \"git clone is primarily used to point to an existing repo and make a clone or copy of that repo at in a new directory, at another location. The original repository can be located on the local filesystem or on remote machine accessible supported protocols. The git clone command copies an existing Git repository. This is sort of like SVN checkout ...\"\n"
" },\n"
" {\n"
" \"title\": \"How To Clone a Git Repository - devconnected\",\n"
" \"href\": \"https://devconnected.com/how-to-clone-a-git-repository/\",\n"
" \"body\": \"In order to clone a git repository into a specific folder, execute the \\\"git clone\\\" command and specify the destination folder at the end. $ git clone <url> <directory>. For example, given the Github project we fetched in the previous section, if we want to clone it into a folder named \\\"myproject\\\" we would run.\"\n"
" },\n"
" {\n"
" \"title\": \"How do I clone a Git repository into a specific folder?\",\n"
" \"href\": \"https://stackoverflow.com/questions/651038/how-do-i-clone-a-git-repository-into-a-specific-folder\",\n"
" \"body\": \"Add a comment. -2. For Windows user 1> Open command prompt. 2> Change the directory to destination folder (Where you want to store your project in local machine.) 3> Now go to project setting online (From where you want to clone) 4> Click on clone, and copy the clone command. 5> Now enter the same on cmd .\"\n"
" },\n"
" {\n"
" \"title\": \"Clone a repository | Bitbucket Cloud | Atlassian Support\",\n"
" \"href\": \"https://support.atlassian.com/bitbucket-cloud/docs/clone-a-repository/\",\n"
" \"body\": \"These instructions show you how to clone your repository using Git from the terminal. In the repository, select the Clone button. Copy the clone command. From a terminal window, change into the local directory where you want to clone your repository. $ cd <path_to_directory> Paste the command you copied from Bitbucket, for example:\"\n"
" },\n"
" {\n"
" \"title\": \"How to clone a git repository using the command line\",\n"
" \"href\": \"https://www.educative.io/answers/how-to-clone-a-git-repository-using-the-command-line\",\n"
" \"body\": \"This particular article will focus on cloning a repository using a command line. Follow the directions below: Open GitHub and go to the GitHub repository that you want to clone. Click \\\"Code\\\" and copy the given URL. click code and copy the URL. Open \\\"Git Bash\\\" and change the current working directory to the location where you want the ...\"\n"
" }\n"
"]")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.