#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\b[a-z]*[A-Za-z][a-z]*\b\s*)+$"
Local $sString = "John Adam Ben" & @CRLF & _
"Dog cat parrot" & @CRLF & _
"sandwich coffee Biscuit" & @CRLF & _
"feel the difference" & @CRLF & _
"" & @CRLF & _
"JOHN ADAM BEN" & @CRLF & _
"DoG cat PaRRoT" & @CRLF & _
"SANDWICH cofee Biscuit" & @CRLF & _
"feeL the diFFerence"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")