// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\b[a-z]*[A-Za-z][a-z]*\b\s*)+$").unwrap();
let string = "John Adam Ben
Dog cat parrot
sandwich coffee Biscuit
feel the difference
JOHN ADAM BEN
DoG cat PaRRoT
SANDWICH cofee Biscuit
feeL the diFFerence";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}