$re = '/(\d+)(?:-)(?![a-z])/';
$str = 'zzz-8-911-aaa-1234567
8-495-1-234-zzz';
$subst = "$1|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;