package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\W|^)(html|CSS|JavaScript)(\W|$)`)
var str = `HTML HTMLDDD d é muito usado nos dias de hoje, juntamente com o HTML usamos JavaScript e CSS...CSS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}