package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([^()]|(?R))*\)`)
var str = `(1, (2, 3)) (4, 5)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}