using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@media.*?(\{([^{}]|(?1))*\})";
string input = @"@media screen and (min-width:750px){h1{font-size:2.5em}}
}
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}