package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@media.*?(\{([^{}]|(?1))*\})`)
var str = `@media screen and (min-width:750px){h1{font-size:2.5em}}
}
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}