import Foundation
let pattern = #"@media.*?(\{([^{}]|(?1))*\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@media screen and (min-width:750px){h1{font-size:2.5em}}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}