re = /\/\*([\S\s]+?)\*\//
str = '/* Comment type1 */
foo
/*
* JD-Core Version: 0.7.0.1
*/
// hello'
# Print the match result
str.match(re) do |match|
puts match.to_s
end