import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-1]?[0-9]|2[0-4])?[0-9]{0,6}(?:\\.[0-9]+)?$";
final String string = "15999999.99\n"
+ "24999999.99\n"
+ "1\n"
+ "25000000.01\n"
+ "1000\n"
+ "123456789\n"
+ "560000.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}