import re
regex = re.compile(r"[{](.+?)[}]|(\w+)")
test_str = ("Alpha Beta C D {e f g} H I {j k l}\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)