import Foundation
let pattern = #"[{](.+?)[}]|(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Alpha Beta C D {e f g} H I {j k l}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)