package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<partbeingcaptured>\-\s*\((?<RetType>.*?)\)\s*)(?<FuncName>(\w+))\s*{`)
var str = `-(void) heyzapCheckinTapped: (id)sender {`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}