const regex = /^(?![0-9a-zA-Z]+:[0-9a-zA-Z]+$).*$\R*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![0-9a-zA-Z]+:[0-9a-zA-Z]+$).*$\\R*', 'gm')
const str = `local06:local16
TEXT local76:local16
local06:local17
local06:local19
More TEXT local76:local678`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);