import Foundation
let pattern = #"^(?![0-9a-zA-Z]+:[0-9a-zA-Z]+$).*$\R*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
local06:local16
TEXT local76:local16
local06:local17
local06:local19
More TEXT local76:local678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)