const regex = /^(\d{4})-(\d{2})-(\d{2})T(\d{2}:\d{2}:\d{2})\.\d+Z$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4})-(\\d{2})-(\\d{2})T(\\d{2}:\\d{2}:\\d{2})\\.\\d+Z$', 'gm')
const str = `2020-03-02T13:40:03.000Z`;
const subst = `$3-$2-$1 $4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);