#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\W+"
Local $sString = "Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)