using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W+";
string substitution = @"-";
string input = @"Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}