import Foundation
let pattern = #"\W+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)