#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(\n|\r|\t|\0|^\s+|\s+$|[\b])"
Local $sString = " no trim is required" & @CRLF & _
"as" & @CRLF & _
" " & @CRLF & _
"bad characters like null, tab, newline, backspace" & @CRLF & _
"" & @CRLF & _
"et.c would be removed substitution is empty string." & @CRLF & _
"" & @CRLF & _
" wohoo " & @CRLF & _
"remove multiline switch in production"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)