const regex = new RegExp('<tr.*?>(<td.*?>|</td>|\\s)*</tr>', '')
const str = `<tr>
<td collspan="5"> <b>Какой-то текст</b>
</td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}