// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/([^_\/]+)(?:_([^_\/]+)?_?)?(?:_([^_\/]+)?_?)?(?:_([^_\/]+)?_?)?\/$").unwrap();
let string = "/some_url/price_desc_30_list/
/some_url/_30/
/some_url/30/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}