using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^net trunk\s+(\S+)[^{]*{.*{ *([^}]*?) *}.*$";
string substitution = @"$1 $2";
string input = @"net trunk RandomNameTrunk { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk DifferentNameTrunk { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled
net trunk trunk#1 { bandwidth 20000 cfg-mbr-count 2 id 0 interfaces { 2.1 2.2 } lacp enabled
net trunk trunk#2 { bandwidth 4000 cfg-mbr-count 2 id 0 interfaces { 1.1 1.2 1.3 1.4 } lacp enabled";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}