use strict;
my $str = '{
var $jqueryFoo = \'foo\';
var bar = \'bar\';
}
{
var foo = require(\'/foo\');
var bar = require(\'/bar\');
var foobar = require(\'/foobar\');
}
{
var foo = \'foo\';
var bar = \'bar\';
var baz;
}
{
var foo = \'foo\';
var bar = \'bar\';
BAZ = \'baz\';
}
{
var foo = \'foo\';
var bar = \'bar\';
var obj = {
foo: \'foo\',
bar: \'bar\'
};
}';
my $regex = qr/(?<=var)(((\s+[\$\w]+[^\n{]*);)(\s+)var)(\s*)(?=(?2))/p;
my $subst = '\\3,\\4 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";