import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\\s]+\\s++){4}(?<logical_system>[\\w]+)[:\\s]";
final String string = "Nov 15 02:51:46 CRTR2OTN.HKB VIASAT2OTN rpd[15644]: bgp_select_myaddr: peer 172.16.145.132 (External AS 64947) local address 172.16.145.129 unavailable, connection failed\n"
+ "Nov 15 02:51:44 CRTR2OTN.SIN rmopd[2167] pingCtlOwnerIndex = Rpm-Bgp-Owner, pingCtlTestName = Rpm-Bgp-Test-7";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}