Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\w+(?=\/NN.?|JJ))
/
gm
Test String
New
(S (NP cured/VBN ham/NN)) (S (NP cured/VBN smoked/VBD beef/NN)) (S (NP curry/NN powder/NN)) (S (NP custard/NN)) (S (NP custard/NN) (NP puerto/JJ rican/JJ style/NN)) (S (NP custard-apple/NN)) (S (NP cytosport/NN muscle/NN milk/NN ready-to-drink/NN)) (S (NP daiquiri/NN)) (S (NP daiquiri/NN) (NP prepared/VBN) --/: (NP recipe/VB)) (S (NP dandelion/NN) greens/NNS) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD butter/NN)) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD margarine/NN)) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD oil/NN)) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD boiled/VBN drained/JJ salt/NN)) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD fat/NN) (NP added/VBD cooking/NN ns/NN type/NN fat/NN)) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD fat/NN) (NP added/VBD cooking/NN)) (S (NP dandelion/NN) greens/NNS (NP cooked/VBD ns/JJ fat/NN) (NP added/VBD cooking/NN)) (S (NP danish/JJ dessert/NN pudding/NN)) (S (NP danish/JJ pastry/NN cheese/NN)) (S (NP danish/JJ pastry/NN cinnamon/NN) (NP enriched/VBD)) (S (NP danish/JJ pastry/NN cinnamon/NN) (NP unenriched/VBD)) (S (NP danish/JJ pastry/NN fruit/NN) (NP enriched/VBD includes/VBZ apple/NN cinnamon/NN raisin/NN lemon/NN raspberry/NN strawberry/NN)) (S (NP danish/JJ pastry/NN fruit/NN) (NP unenriched/VBD includes/VBZ apple/NN cinnamon/NN raisin/NN strawberry/NN)) (S (NP danish/JJ pastry/NN lemon/NN) (NP unenriched/VBD)) (S (NP danish/JJ pastry/NN raspberry/NN) (NP unenriched/VBD)) (S (NP dark/JJ) (NP chocolate/VB 45-59/JJ %/NN cocoa/NN)) (S (NP dark/JJ) (NP chocolate/VB 60-69/JJ %/NN cocoa/NN)) (S (NP dark/JJ) (NP chocolate/VB 70-85/JJ %/NN cocoa/NN)) (S (NP dark/JJ chocolate/NN) (NP coated/VBD coffee/NN) beans/NNS) (S (NP dasheen/NN) (NP boiled/VBD)) (S (NP dasheen/NN) (NP fried/VBD)) (S (NP date/NN candy/NN)) (S dates/NNS (NP deglet/VBP noor/JJ)) (S (NP decaf/NN coffee/NN)) (S (NP deer/NN chop/NN) (NP cooked/VBD)) (S (NP dehydrated/VBN milk/NN)) (S (NP dessert/NN dip/NN)) (S (NP dessert/NN pizza/NN)) (S (NP dessert/NN sauce/NN)) (S (NP dessert/NN topping/NN) (NP powdered/VBD)) (S (NP dessert/NN topping/NN) (NP powdered/VBD 1.5/CD) (NP ounce/NN) (NP prepared/VBD 1/2/CD) cup/NNS (NP milk/NN))