#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+(?=\/NN.?|JJ))"
Local $sString = "(S (NP cured/VBN ham/NN))" & @CRLF & _
"(S (NP cured/VBN smoked/VBD beef/NN))" & @CRLF & _
"(S (NP curry/NN powder/NN))" & @CRLF & _
"(S (NP custard/NN))" & @CRLF & _
"(S (NP custard/NN) (NP puerto/JJ rican/JJ style/NN))" & @CRLF & _
"(S (NP custard-apple/NN))" & @CRLF & _
"(S (NP cytosport/NN muscle/NN milk/NN ready-to-drink/NN))" & @CRLF & _
"(S (NP daiquiri/NN))" & @CRLF & _
"(S (NP daiquiri/NN) (NP prepared/VBN) --/: (NP recipe/VB))" & @CRLF & _
"(S (NP dandelion/NN) greens/NNS)" & @CRLF & _
"(S (NP dandelion/NN) greens/NNS (NP cooked/VBD butter/NN))" & @CRLF & _
"(S (NP dandelion/NN) greens/NNS (NP cooked/VBD margarine/NN))" & @CRLF & _
"(S (NP dandelion/NN) greens/NNS (NP cooked/VBD oil/NN))" & @CRLF & _
"(S" & @CRLF & _
" (NP dandelion/NN)" & @CRLF & _
" greens/NNS" & @CRLF & _
" (NP cooked/VBD boiled/VBN drained/JJ salt/NN))" & @CRLF & _
"(S" & @CRLF & _
" (NP dandelion/NN)" & @CRLF & _
" greens/NNS" & @CRLF & _
" (NP cooked/VBD fat/NN)" & @CRLF & _
" (NP added/VBD cooking/NN ns/NN type/NN fat/NN))" & @CRLF & _
"(S" & @CRLF & _
" (NP dandelion/NN)" & @CRLF & _
" greens/NNS" & @CRLF & _
" (NP cooked/VBD fat/NN)" & @CRLF & _
" (NP added/VBD cooking/NN))" & @CRLF & _
"(S" & @CRLF & _
" (NP dandelion/NN)" & @CRLF & _
" greens/NNS" & @CRLF & _
" (NP cooked/VBD ns/JJ fat/NN)" & @CRLF & _
" (NP added/VBD cooking/NN))" & @CRLF & _
"(S (NP danish/JJ dessert/NN pudding/NN))" & @CRLF & _
"(S (NP danish/JJ pastry/NN cheese/NN))" & @CRLF & _
"(S (NP danish/JJ pastry/NN cinnamon/NN) (NP enriched/VBD))" & @CRLF & _
"(S (NP danish/JJ pastry/NN cinnamon/NN) (NP unenriched/VBD))" & @CRLF & _
"(S" & @CRLF & _
" (NP danish/JJ pastry/NN fruit/NN)" & @CRLF & _
" (NP" & @CRLF & _
" enriched/VBD" & @CRLF & _
" includes/VBZ" & @CRLF & _
" apple/NN" & @CRLF & _
" cinnamon/NN" & @CRLF & _
" raisin/NN" & @CRLF & _
" lemon/NN" & @CRLF & _
" raspberry/NN" & @CRLF & _
" strawberry/NN))" & @CRLF & _
"(S" & @CRLF & _
" (NP danish/JJ pastry/NN fruit/NN)" & @CRLF & _
" (NP" & @CRLF & _
" unenriched/VBD" & @CRLF & _
" includes/VBZ" & @CRLF & _
" apple/NN" & @CRLF & _
" cinnamon/NN" & @CRLF & _
" raisin/NN" & @CRLF & _
" strawberry/NN))" & @CRLF & _
"(S (NP danish/JJ pastry/NN lemon/NN) (NP unenriched/VBD))" & @CRLF & _
"(S (NP danish/JJ pastry/NN raspberry/NN) (NP unenriched/VBD))" & @CRLF & _
"(S (NP dark/JJ) (NP chocolate/VB 45-59/JJ %/NN cocoa/NN))" & @CRLF & _
"(S (NP dark/JJ) (NP chocolate/VB 60-69/JJ %/NN cocoa/NN))" & @CRLF & _
"(S (NP dark/JJ) (NP chocolate/VB 70-85/JJ %/NN cocoa/NN))" & @CRLF & _
"(S (NP dark/JJ chocolate/NN) (NP coated/VBD coffee/NN) beans/NNS)" & @CRLF & _
"(S (NP dasheen/NN) (NP boiled/VBD))" & @CRLF & _
"(S (NP dasheen/NN) (NP fried/VBD))" & @CRLF & _
"(S (NP date/NN candy/NN))" & @CRLF & _
"(S dates/NNS (NP deglet/VBP noor/JJ))" & @CRLF & _
"(S (NP decaf/NN coffee/NN))" & @CRLF & _
"(S (NP deer/NN chop/NN) (NP cooked/VBD))" & @CRLF & _
"(S (NP dehydrated/VBN milk/NN))" & @CRLF & _
"(S (NP dessert/NN dip/NN))" & @CRLF & _
"(S (NP dessert/NN pizza/NN))" & @CRLF & _
"(S (NP dessert/NN sauce/NN))" & @CRLF & _
"(S (NP dessert/NN topping/NN) (NP powdered/VBD))" & @CRLF & _
"(S" & @CRLF & _
" (NP dessert/NN topping/NN)" & @CRLF & _
" (NP powdered/VBD 1.5/CD)" & @CRLF & _
" (NP ounce/NN)" & @CRLF & _
" (NP prepared/VBD 1/2/CD)" & @CRLF & _
" cup/NNS" & @CRLF & _
" (NP milk/NN))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")