re = /^ *if \(.+\).*({)/im
str = '// Don\'t match these
if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == \'a\') SomeFunction(); // And a comment
if () asdf sdf sd sdfsdf; // Another comment
don\'t match this line if (asdfsad == 3425435) a; // Another comment
// Match these
if (something) { // A comment
}
if (assda) { // Another comment
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end