// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^ *if \(.+\).*({)").unwrap();
let string = "// Don't match these
if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == 'a') SomeFunction(); // And a comment
if () asdf sdf sd sdfsdf; // Another comment
don't match this line if (asdfsad == 3425435) a; // Another comment
// Match these
if (something) { // A comment
}
if (assda) { // Another comment
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}