package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(January|February|March|April|May|June|July|August|September|October|November|December)[ ](0[1-9]|[1-2][0-9]|3[0-1])[,][ ](20)[0-9]{2}`)
var str = `The owners of this address received a permit on Wednesday, June 14, 2013
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}