package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*?)\|(.*?)\]`)
var str = `gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii`
var substitution = "$2 (vk.com/$1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}