re = /\[(.*?)\|(.*?)\]/
str = 'gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii'
subst = '$2 (vk.com/$1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result