$re = '/<(data-hora)>(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})[\d\-\.:]*<\/\1>/';
$str = '<data-hora>2015-11-10T11:33:41.086-02:00</data-hora>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);