using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GB(\s?\d){9}";
string input = @"GB009000909
GB 009000909
GB00 9 00 0 909
GB00 9 000 9 09
GB0 0 9 0 0 0 9 0 9
GB00 90 00 909
GB009 000909
GB00900 090 9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}