$re = '/GB(\s?\d){9}/m';
$str = 'GB009000909
GB 009000909
GB00 9 00 0 909
GB00 9 000 9 09
GB0 0 9 0 0 0 9 0 9
GB00 90 00 909
GB009 000909
GB00900 090 9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);