using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(First Name) +(\S+)|(Last Name) +(\S+)|(City) +(\S+)";
string input = @"First Name Guilherme
Last Name Souza
City Piracicaba";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}