using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Received:\s+(?P<myfield>.+\;[\r|\n].+)";
string input = @"Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;
Fri, 2 Jan 2015 12:46:51 -0800 (PST)
X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;
Fri, 02 Jan 2015 12:46:51 -0800 (PST)
Return-Path: ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}