using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\b5\*14\b.*?\b(\d+\.\d+)";
string input = @"120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}