// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\b5\*14\b.*?\b(\d+\.\d+)").unwrap();
let string = "120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}